Leaderboards are offline due to spike in latencies
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Jan 26, 2020 - 17:07 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 26, 2020 - 09:28 PST
Investigating
We are currently investigating this issue.
Posted Jan 26, 2020 - 08:29 PST
This incident affected: Dashboard.