Subscriptions are currently unavailable
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 08:20 PDT
Monitoring
Subscriptions are returning to normal operation.
Posted Jun 18, 2020 - 08:11 PDT
Update
We are continuing to investigate this issue.
Posted Jun 18, 2020 - 07:49 PDT
Investigating
We are currently investigating an issue preventing subscription actions from being available on Desktop, Xbox and Android.
Posted Jun 18, 2020 - 07:45 PDT
This incident affected: Mixer Web Experience and Channel Subscriptions.