Top streams may show incorrect viewer counts
Incident Report for Mixer
Resolved
Viewer counts for the top viewers row are now updating properly.
Posted May 21, 2020 - 15:35 PDT
Identified
Our engineers have identified an issue that is preventing viewer counts being updated for the top streams row on mixer.com and are working to fix it.

Channel pages will show the correct viewer count.
Posted May 21, 2020 - 15:15 PDT
This incident affected: Mixer Web Experience and Mixer Xbox App.