Issues granting Mixer Loot for Apex
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 02, 2019 - 18:40 PDT
Investigating
Apex Loot is currently experiencing issues granting and tracking loot objectives; our engineers are working to resolve.
Posted 3 months ago. Jul 02, 2019 - 15:04 PDT
This incident affected: Mixer Web Experience.