Trouble loading Mixer section of Home on the Xbox
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Dec 14, 2019 - 16:20 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 14, 2019 - 16:18 PST
Monitoring
The Mixer Xbox experience has been fully restored but are going to continue monitoring for issues.
Posted Dec 14, 2019 - 15:15 PST
Update
The failing service call has been identified and a mitigation is being implemented.
Posted Dec 14, 2019 - 15:08 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 14, 2019 - 15:08 PST
Investigating
The Mixer section of Xbox Home is currently unable to display content due to a failed service call. We are currently investigating this issue.
Posted Dec 14, 2019 - 14:16 PST
This incident affected: Mixer Xbox App.