Issue with spark crystal updating
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 26, 2019 - 19:16 PDT
Investigating
We are currently investigating the issue
Posted 4 months ago. Jun 26, 2019 - 18:24 PDT
This incident affected: Skills (Sparks and Embers).