Issues signing into Mixer for some users
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 19:58 PST
Identified
We are aware of some users receiving errors when trying to log into Mixer and working to resolve.
Posted Feb 21, 2020 - 16:46 PST
This incident affected: Mixer Web Experience.