Issue Purchasing Embers
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 24, 2019 - 17:15 PDT
Investigating
We are currently investigating the issue.
Posted 3 months ago. Jul 24, 2019 - 15:00 PDT
This incident affected: Skills (Sparks and Embers).