Users may experience issues signing in or using the site
Incident Report for Mixer
Resolved
The issue has been resolved and users should be able to use the site.
Posted about 1 month ago. Jul 15, 2019 - 18:43 PDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Jul 15, 2019 - 17:34 PDT
This incident affected: Mixer API, Mixer Web Experience, and Mixer Xbox App.