Paypal based auto-renewing Channel Subs are failing to auto-renew
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 20:26 PDT
Investigating
We are currently investigating this issue.
Posted Mar 13, 2020 - 13:59 PDT