Issue redeeming Embers
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Aug 01, 2019 - 16:36 PDT
Investigating
Some users may experience problems redeeming Embers on the Xbox.
Posted Aug 01, 2019 - 15:37 PDT
This incident affected: Skills (Sparks and Embers).