Issues accessing and using the site
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Jun 04, 2019 - 19:11 PDT
Identified
Mixer engineers have identified the issue and are working to resolve it.
Posted Jun 04, 2019 - 18:52 PDT
Investigating
Some users may experience issues loading the site or user's streams. Our engineers are investigating.
Posted Jun 04, 2019 - 18:30 PDT
This incident affected: Mixer API, Mixer Web Experience, and Mixer Xbox App.