FTL - High packet loss in NYC region affecting Comcast users
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 21:59 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 25, 2020 - 16:53 PST
Monitoring
Comcast viewers in NYC and the surrounding areas are experiencing a high degree of packet loss resulting in a low quality video experience for FTL streams. We are actively investigating. If you are having trouble in this region please try switching off low latency in the cog menu in the bottom right corner of the video player
Posted Feb 25, 2020 - 15:12 PST
This incident affected: Video Distribution (FTL (Low Latency) Video Delivery).