Username change issues
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 14, 2019 - 15:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Aug 10, 2019 - 12:48 PDT
Identified
Users may be unable to change their usernames after the 30 day cooldown period. Please keep an eye on this status page for updates.
Posted 2 months ago. Aug 10, 2019 - 12:47 PDT
This incident affected: Mixer API.