Trouble loading Mixer homepage on Mobile devices
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Dec 14, 2019 - 16:40 PST
Update
We are currently investigating the inability to load content on the homepage of the Mixer Android and iOS apps. We are also investigation a "something went wrong" message when loading the Mixer.com homepage.
Posted Dec 14, 2019 - 16:23 PST
Investigating
We are currently investigating the inability to load content on the homepage of the Mixer Android and iOS apps.
Posted Dec 14, 2019 - 16:07 PST
This incident affected: Mixer Web Experience.