Mixer Xbox App not loading
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Jun 03, 2019 - 14:09 PDT
Investigating
We are currently investigating an issue where the Mixer App fails to load on Xbox.
Posted Jun 03, 2019 - 13:11 PDT
This incident affected: Mixer Xbox App.