Unable to use and purchase Embers
Incident Report for Mixer
Resolved
Embers and Sparks are back to working.
Posted Oct 16, 2019 - 14:09 PDT
Investigating
We are currently investigating an issue where Embers and Sparks are not able to be used.
Posted Oct 16, 2019 - 10:06 PDT
This incident affected: Skills (Sparks and Embers).