Missing Thumbnails
Incident Report for Mixer
Resolved
Issue resolved and all thumbnails have fully recovered.
Posted Mar 15, 2020 - 20:59 PDT
Monitoring
Due to the recent issues, some channel thumbnails are still missing. We are aware of this issue and they are in process of being restored. A few channels may require restarting their stream to fully recover, but doesn't impact viewers from access or enjoying their favorite streamers channel.
Posted Mar 15, 2020 - 15:54 PDT
This incident affected: Mixer Web Experience.