Mixer Channel Leaderboards displaying incorrect information
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Apr 09, 2020 - 16:27 PDT
Investigating
Our engineers are currently investigating an issue with our Leaderboard service provider. Ember donations may not reflect correctly on a Channel Leaderboard at this time.
Posted Apr 08, 2020 - 20:59 PDT
This incident affected: Mixer Web Experience and Mixer Xbox App.