Apex Loot experienced an error granting loot
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 01, 2019 - 12:36 PDT
Monitoring
Please refresh your browser to fix the problem.
Posted 3 months ago. Jul 01, 2019 - 12:02 PDT