Issues claiming Loot
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Jul 03, 2019 - 15:31 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2019 - 15:14 PDT
Investigating
We are investigating issues claiming Loot.
Posted Jul 03, 2019 - 12:19 PDT
This incident affected: Mixer Web Experience.