Partnership applications cannot be submitted or may be delayed
Incident Report for Mixer
Resolved
Our partners have completed their work and users should be able to submit partnership applications again. Users who tried to submit an application during this outage and received an error will need to resubmit their application. Please reach out to our support team if you are still encountering issues.
Posted May 20, 2020 - 12:25 PDT
Identified
The cause has been identified and our partner team is working to mitigate the issue.
Posted May 20, 2020 - 12:15 PDT
Investigating
We are aware of an issue that is preventing users from submitting partnership applications and that is delaying applications from being processed.
Posted May 20, 2020 - 11:17 PDT