Some features temporarily disabled
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Jun 09, 2019 - 19:04 PDT
Identified
During parts of E3, some features of the site have been disabled. All features will be re-enabled after Monday's Inside Xbox show.
Posted Jun 09, 2019 - 10:55 PDT