Issues signing in, creating, managing, or recovering an account.
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted 16 days ago. Sep 06, 2019 - 21:19 PDT
Update
We are continuing to investigate this issue.
Posted 16 days ago. Sep 06, 2019 - 20:00 PDT
Investigating
We are currently investigating the issue.
Posted 16 days ago. Sep 06, 2019 - 17:26 PDT
This incident affected: Mixer Web Experience and Mixer Xbox App.