Issues getting FTL is north east for comcast users
Incident Report for Mixer
Resolved
This incident has been resolved.
Posted Mar 03, 2020 - 21:57 PST
Investigating
Users on comcast in the north east of the US may have trouble getting FTL. We are actively working to mitigate the issue.
Posted Mar 03, 2020 - 19:59 PST
This incident affected: Video Distribution (FTL (Low Latency) Video Delivery).