Sign-in and purchase issues
Incident Report for Mixer
Resolved
Our partners have resolved the issue and users should be able to use the site and all listed features.
Posted 2 months ago. Aug 07, 2019 - 11:05 PDT
Identified
Our partners have identified an issue that may prevent users from accessing parts of Mixer. Impacted areas include sign-in, new user registration, and purchase functionality on some platforms.
Posted 2 months ago. Aug 06, 2019 - 16:06 PDT
This incident affected: Mixer API, Mixer Web Experience, Mixer Xbox App, and Skills (Sparks and Embers).